RE: [EPP-discuss] epp errors in production?

From: Boris Fernandez <Boris.Fernandez_at_ascio.com>
Date: Mon, 20 Oct 2014 13:57:52 +0000

I do not have that problem with the start. I see the full XML.

Though the fact you do not have it at the end is normal and I believe is happening with every single command. It is just the xml declaration. It is not really a processing instruction. It is only there to configure the XML parser.

Here see for Afilias :

<?xml version='1.0' encoding='UTF-8'?>
        <epp xmlns='urn:ietf:params:xml:ns:epp-1.0' xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance' xsi:schemaLocation='urn:ietf:params:xml:ns:epp-1.0 epp-1.0.xsd'>
                <greeting>
                        <svID>Redwood EPP Server</svID>
                        <svDate>2014-10-20T00:34:30.0Z</svDate>
                        <svcMenu>
                                <version>1.0</version>
                                <lang>en-US</lang>
                                <objURI>urn:ietf:params:xml:ns:domain-1.0</objURI>
                                <objURI>urn:ietf:params:xml:ns:host-1.0</objURI>
                                <objURI>urn:ietf:params:xml:ns:contact-1.0</objURI>
                                <svcExtension>
                                        <extURI>urn:afilias:params:xml:ns:oxrs-1.1</extURI>
                                        <extURI>urn:ietf:params:xml:ns:rgp-1.0</extURI>
                                        <extURI>urn:afilias:params:xml:ns:ipr-1.1</extURI>
                                        <extURI>urn:afilias:params:xml:ns:idn-1.0</extURI>
                                        <extURI>urn:ietf:params:xml:ns:secDNS-1.1</extURI>
                                        <extURI>urn:ietf:params:xml:ns:launch-1.0</extURI>
                                </svcExtension>
                        </svcMenu>
                        <dcp>
                                <access>
                                        <personal/>
                                </access>
                                <statement>
                                        <purpose>
                                                <admin/>
                                                <other/>
                                        </purpose>
                                        <recipient>
                                                <ours>
                                                        <recDesc>Afilias Limited</recDesc>
                                                </ours>
                                                <public/>
                                                <same/>
                                                <unrelated/>
                                        </recipient>
                                        <retention>
                                                <business/>
                                        </retention>
                                </statement>
                                <expiry>
                                        <relative>P10Y0M0DT0H0M0.0S</relative>
                                </expiry>
                        </dcp>
                </greeting>
        </epp>


-----Original Message-----
From: Peter Larsen [mailto:peter.larsen_at_larsendata.dk]
Sent: 20. oktober 2014 15:45
To: EPP-discuss_at_liste.dk-hostmaster.dk
Subject: [EPP-discuss] epp errors in production?

i am seeing funny issues on some of the xml schemas i get in return of = requests, missing 4 chars in the beginning and the end of every xml =
given to me, eg missing <?xm and xml>:


<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
l version=3D"1.0" encoding=3D"utf-8" standalone=3D"no"?> <epp xmlns=3D"urn:ietf:params:xml:ns:epp-1.0">
    <greeting>
        <svID>DK Hostmaster EPP Service (production): 1.1.0</svID>
        <svDate>2014-10-20T13:16:35.0Z</svDate>
        <svcMenu>
            <version>1.0</version>
            <lang>en</lang>
            <objURI>urn:ietf:params:xml:ns:host-1.0</objURI>
            <objURI>urn:ietf:params:xml:ns:domain-1.0</objURI>
            <objURI>urn:ietf:params:xml:ns:contact-1.0</objURI>
            <svcExtension>
                <extURI>urn:ietf:params:xml:ns:secDNS-1.1</extURI>
                <extURI>urn:dkhm:params:xml:ns:dkhm-1.2</extURI>
            </svcExtension>
        </svcMenu>
        <dcp>
            <access>
                <personalAndOther />
            </access>
            <statement>
                <purpose>
                    <admin />
                    <prov />
                </purpose>
                <recipient>
                    <other />
                    <unrelated />
                </recipient>
                <retention>
                    <legal />
                </retention>
            </statement>
        </dcp>
    </greeting>
</epp>
?
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
Received on Mon Oct 20 2014 - 15:57:52 CEST

This archive was generated by hypermail 2.3.0 : Fri Feb 06 2015 - 11:39:28 CET